Planet Express Special Episode I Download PEC-Tool v1.83

Zusammenfassung aller Planet Express Folgen

Re: Planet Express Special Episode I Download PEC-Tool v1.81

Beitragvon Bonejones am Do 7. Mär 2013, 22:45

Release version 1.81
Transplan 1.3x
Update Minor Fixes


Release version 1.82
Simulator
Einige Werte im Spiel wurden geändert, die Grundwerte für AK/VK der Träger sind entfallen und die Werte der Fregatte verändert. Kampfkraft und Besatzung.
Diese sind in den Simulator, Trägerdaten, Trägertower, FlottenManager eingeflossen was einige Stunden und Nerven gekostet hat.

Da ich die Entwicklung der Tabelle für den Download mittlerweile mangels Feedback eingestellt habe ist das eine Umwandlung meiner eigenen Fassung, inzwischen v1.81.

Das hat aber den unangenehmen Nebeneffekt das ich diverse Änderungen nicht mehr dokumentiert habe. Zudem ist zu beachten das es eine angefangene Tabelle Zentrale Konfiguration gibt in der aber nur ein Wert interessant ist, der Rassenboost.
Das entsprechende Feld habe ich farblich markiert. Die Eingabe ist eine 1 für keinen Boost und z.b. 1,01 für 1%. Dieser Wert hat Einfluss auf die Rohstoff und Bauzeitberechnungen in den anderen Tabellen.

Sofern sich nicht weitere Änderungen an den Einheitenwerten ist die Entwicklung mangels Nachfrage nunmehr endgültig eingestellt.

Auf der <<< Download-Site >>>
Benutzeravatar
Bonejones
 
Beiträge: 281
Registriert: So 29. Jul 2012, 11:39

Re: Planet Express Special Episode I Download PEC-Tool v1.81

Beitragvon Bonejones am Fr 8. Mär 2013, 20:19

Release version 1.83
Simulator
critical fix
Bei der neuen Gestaltung ist ein Zellenbezug verrutscht der nun im Ergebnisfeld die VK der Angreiferflotte in das Feld für die Ak eingetragen hat.

Auf der <<< Download-Site >>>[/quote]
Benutzeravatar
Bonejones
 
Beiträge: 281
Registriert: So 29. Jul 2012, 11:39

Re: Planet Express Special Episode I Download PEC-Tool v1.83

Beitragvon Bonejones am Fr 26. Jul 2013, 02:42

Ich habe einen "Bug" in dem s&w calc entdeckt der nur in einem seltenem Sonderfall auftaucht
(war heute tatsächlich das erste Mal).

Fall: Wenn in einer Station, eine durch 10.000 Teilbare Rohstoffsumme ohne Rest vorgefunden wird, berechnet die Tabelle die Zahl der nötigen Hauler fehlerhaft; (es wird ein Hauler zuviel angezeigt).

Um diesen Fehler zu korrigieren müssen in 6 Zellen die Formlen leicht angepasst werden.
Die Zellen K27, K28 und K29 müssen im ersten Vergleich statt der > Funktion ein >= enthalten.
=WENN(K25>=K26; .... statt =WENN(K25>K26;.....

Ebenso die Zellen J27, J28 und J29
=WENN(J25>=J26;..... statt =WENN(J25>J26;.....

CODE Komplett: Spoiler K27
Code: Alles auswählen
=WENN(K25>=K26;WENN(C34>B33;WENN(K26>I20;"Traumhaft- abräumer!";WENN(K26>I19;"Sehr gut - abräumer!";WENN(K26>I18;"Gut - abräumer!";WENN(K26>I17;"Ok - abräumer!";WENN(K26>I16;"Akzeptabel - abräumer!";WENN(K26>I15;"Riskant - abräumer!";"VERLUST! (abräumer)"))))));WENN(K25>I20;"Traumhaft- nur volle!";WENN(K25>I19;"Sehr gut - nur volle!";WENN(K25>I18;"Gut - nur volle!";WENN(K25>I17;"Ok - nur volle!";WENN(K25>I16;"Riskant - nur volle!";WENN(K25>I15;"Hohes Risiko - nur volle!";"VERLUST! (nur volle)")))))));WENN(K26>I20;"Traumhaft- alles!";WENN(K26>I19;"Sehr gut - alles!";WENN(K26>I18;"Gut - alles!";WENN(K26>I17;"Ok - alles!";WENN(K26>I16;"Akzeptabel - alles!";WENN(K26>I15;"Riskant - alles!";"VERLUST! (alles)")))))))


K28
Code: Alles auswählen
=WENN(K25>=K26;WENN(C34>B33;$D$26;$D$25);$D$26)


K29
Code: Alles auswählen
=WENN(K25>=K26;WENN(C34>B33;$B$25+1;$B$25);$B$25+1)


J27
Code: Alles auswählen
=WENN(J25>=J26;WENN(C33>B33;WENN(J26>I20;"Traumhaft- alles!";WENN(J26>I19;"Sehr gut - abräumer!";WENN(J26>I18;"Gut - abräumer!";WENN(J26>I17;"Ok - abräumer!";WENN(J26>I16;"Akzeptabel - abräumer!";WENN(J26>I15;"Riskant - abräumer!";"VERLUST! (abräumer)"))))));WENN(J25>I20;"Traumhaft- nur volle!";WENN(J25>I19;"Sehr gut - nur volle!";WENN(J25>I18;"Gut - nur volle!";WENN(J25>I17;"Ok - nur volle!";WENN(J25>I16;"Aktzeptabel - nur volle!";WENN(J25>I15;"Riskant - nur volle!";"VERLUST! (nur volle)")))))));WENN(J26>I20;"Traumhaft- alles!";WENN(J26>I19;"Sehr gut - alles!";WENN(J26>I18;"Gut - alles!";WENN(J26>I17;"Ok - alles!";WENN(J26>I16;"Riskant - alles!";WENN(J26>I15;"Hohes Risiko - alles!";"VERLUST! (alles)")))))))


J28
Code: Alles auswählen
=WENN(J25>=J26;WENN(C33>B33;$D$26;$D$25);$D$26)


J29
Code: Alles auswählen
=WENN(J25>=J26;WENN(C33>B33;$B$25+1; $B$25);$B$25+1)

Der Fehler ist bei der implementierung der "letzter Hauler" Funktion entstanden..
Die Code für die jeweilige Zelle ist im Spoiler zu finden und kann via Copy und Paste eingefügt werden.

so long

Bone
Benutzeravatar
Bonejones
 
Beiträge: 281
Registriert: So 29. Jul 2012, 11:39

Re: Planet Express Special Episode I Download PEC-Tool v1.83

Beitragvon Bonejones am Di 17. Jun 2014, 09:32

Es ist ggf eine neue - verkürzte Version des PEC-Tool geplant. Außer einigen kleinen Feherbeseitigungen sind eine Verbesserung und Erweiterung der Simulators und ein Angriffswellen-planer angedacht. Zudem geht aus der Entwicklung ggf. eine Sreenreader-version hervor.

Es gibt eine Umfrage die den Bedarf feststellen soll und bei der abgestimmt werden kann welche Funktionen des PEC-Tools von Euch genutzt werden. Ich bitte um Teilnahme, bei zu geringen Interesse wird es keine Download-Fassung geben. Bitte bei der Abstimmung auf die tatsächlich genutzen PEC Funktionen beschränken da dies den Aufwand und die Entwicklungszeit erheblich verkürzen könne.

Da ich hier keine Umfragen erstellen kann dienst hierzu wieder einmal der zentrale Datenkern im Bereich open-public.
Zur Umfrage - Welche Funktionen des PEC-Tool werden genutzt?

so long

Bone
Benutzeravatar
Bonejones
 
Beiträge: 281
Registriert: So 29. Jul 2012, 11:39

Vorherige

Zurück zu Planet Express

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron